Chrarging Problems - Charge Battery, etc. 500 series

If you have charging issues with your 500 series instrument, there are a few things that can be looked at. First of all, there are some older versions of firmware where the instrument may go into a "trickle charge". If you are having charging issues, unplug the device from the power supply. Turn the instrument off by pushing the battery saver button on the bottom of the unit. Wait about 10 seconds, then plug the unit back in to the power supply. After doing this, make sure you keep the unit plugged in for at least 3 hours uninterrupted, not pushing any buttons or taking readings or anything. In some cases this will solve the problem. If this does not work, the power supply may be at fault. Check the power supply with a voltmeter and see if you are getting the correct voltage from the power supply. If not, you may need a new power supply. If the power supply is getting enough voltage, it is more than likely the battery. Plug in the unit so you can get power to the unit. From the main menu, go to Configuration and hit the Enter Key (bottom right hand key). From the Configuration, select Display and hit your Enter key again. Scroll down to Battery Status and hit your Enter key again. Your readings for both Idle and Measure should read over 5.00V or the battery is not getting the correct voltage. If it is less, and the power supply is getting the correct voltage, you should order a new battery.

Questions? Need a Quote? Contact Us.  1.800.248.9748