Vista EZcolor compatibility

On February 26, 2007 EZcolor 2.6.5, which provides support for Microsoft Vista (32 bit) was released. This new version also allows you take advantage of an expanded set of monitor calibration devices such as Eye-One Display 2, a product formally offered by GretagMacbeth (Now part of X-Rite).

You must be running MonacoEZcolor version v2.50 or higher to take advantage of this free upgrade.

You may download EZcolor version 2.6.5 from the following link, please be sure to carefully read and follow the installation instructions on this page. Also remember to install the software before connecting your instrument so that the drivers are properly installed.

Questions? Need a Quote? Contact Us.  1.800.248.9748