SVC Bulletin--Loading Firmware with ToolCrib on Vista

Loading Firmware with ToolCrib on Vista

Technical Service Bulletin

Bulletin #

Date Issued

XR-0910-1001

October 1, 2009

Subject

Loading firmware with ToolCrib running on Vista OS.

 

Affected Models

Firmware Version

Software Version

ITX –Density

v09609 or lower

v1.5

ITX –Spectral

v09609 or lower

v1.5

ITX –ICC

v09609 or lower

v1.5

 

Description

When loading firmware in the standard out-of-the-box configuration on Windows Vista; the system will fail to load the firmware.

Standard Out-Of-The-Box Configuration

1. Standard IP address of 172.16.1.100

2. Computer connected directly to the track using the yellow cross-over cable that ship with the system.

 

 

 

 

 

 

 


The issue is due to how Vista supports ARP packets (Address Resolution Protocol). These packets, when loading station firmware, will change the IP address of the track to match the IP address of the computer resulting in the error message below.

 

 

 

 

 

 

Current Solutions

There are two solutions for this issue.

Solution 1—Route Through a Hub in Static IP Using 172.16.1.100

This solution includes purchasing an inexpensive Ethernet hub and an additional Ethernet cable then inserting them between the station and the computer. The hub will filter the ARP packets out of the data packets while the firmware is being loaded into the station.

 

 

 

 

 

 

Solution 2—Connect in DHCP Mode

This solution implies there is a DHCP server on the network. Plug the track and computer directly to the network using a LAN connection. Refer to the operation manual for instruction on how to configure the system for DHCP connection. The DHCP will act like the hub and filter the ARP packets out of the data packets while the firmware is being loaded into the station.

 

 

 

 

 

Questions? Need a Quote? Contact Us.  1.800.248.9748